Switch from GPL CRC code to public domain CRC code
[httpd-crcsyncproxy.git] / debian / rules
blob79a24e39eecae17f68ee5343f1bd807ab04f4d1d
1 #!/usr/bin/make -f
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 APXS=/usr/bin/apxs2
8 build: build-stamp
9 build-stamp:
10 dh_testdir
12 # Add here commands to compile the package.
13 $(MAKE)
15 touch $@
17 clean:
18 dh_testdir
19 dh_testroot
20 rm -f build-stamp
22 # Add here commands to clean up after the build process.
23 $(MAKE) clean
25 dh_clean
27 install: build
28 dh_testdir
29 dh_testroot
30 dh_prep
31 dh_installdirs
33 # Add here commands to install the package into debian/tmp
34 $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
37 # Build architecture-independent files here.
38 binary-indep: install
39 # We have nothing to do by default.
41 # Build architecture-dependent files here.
42 binary-arch: install
43 dh_testdir
44 dh_testroot
45 dh_installchangelogs
46 dh_installdocs
47 dh_installexamples
48 dh_install
49 dh_installman
50 dh_link
51 dh_strip
52 dh_compress
53 dh_fixperms
54 dh_installdeb
55 dh_shlibdeps
56 dh_gencontrol
57 dh_md5sums
58 dh_builddeb
60 binary: binary-indep binary-arch
61 .PHONY: build clean binary-indep binary-arch binary install