4 Summary: A wiki compiler
6 Group: Applications
/Internet
8 URL: http
://ikiwiki.info
/
9 Source0: http
://ftp.debian.org
/debian
/pool
/main
/i
/%{name}/%{name}_%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
13 BuildRequires
: perl
(Text
::Markdown
)
14 BuildRequires
: perl
(Mail
::Sendmail
)
15 BuildRequires
: perl
(HTML
::Scrubber
)
16 BuildRequires
: perl
(XML
::Simple
)
17 BuildRequires
: perl
(Date
::Parse
)
18 BuildRequires
: perl
(Date
::Format
)
19 BuildRequires
: perl
(HTML
::Template
)
20 BuildRequires
: perl
(CGI
::FormBuilder
)
21 BuildRequires
: perl
(CGI
::Session
)
22 BuildRequires
: perl
(File
::MimeInfo
)
23 BuildRequires
: gettext
26 Requires: perl
(:MODULE_COMPAT_%
(eval "`
%{__perl} -V
:version`"
; echo $version
))
28 Requires: perl
(Text
::Markdown
)
29 Requires: perl
(Mail
::Sendmail
)
30 Requires: perl
(HTML
::Scrubber
)
31 Requires: perl
(XML
::Simple
)
32 Requires: perl
(CGI
::FormBuilder
)
33 Requires: perl
(CGI
::Session
)
34 Requires: perl
(Digest
::SHA1
)
36 Requires: python
-docutils
38 %define cgi_bin
%{_libexecdir}/w3m
/cgi
-bin
42 Ikiwiki is a wiki compiler. It converts wiki pages into HTML pages
43 suitable
for publishing on a website. Ikiwiki stores pages and
history
44 in a revision control system such as Subversion or Git. There are many
45 other features
, including support
for blogging
, as well as a large
52 # Filter unwanted Provides:
53 %{__cat} << \EOF > %{name}-prov
55 %{__perl_provides} $
* |\
56 %{__sed} -e '
/perl
(IkiWiki.
*)/d'
59 %define __perl_provides
%{_builddir}/%{name}/%{name}-prov
60 %{__chmod} +x %{__perl_provides}
62 # Filter Requires, all used by plugins
63 # - Monotone: see bz 450267
64 %{__cat} << \EOF > %{name}-req
66 %{__perl_requires} $
* |\
67 %{__sed} -e '
/perl
(IkiWiki.
*)/d' \
68 -e '
/perl
(Monotone
)/d'
71 %define __perl_requires
%{_builddir}/%{name}/%{name}-req
72 %{__chmod} +x %{__perl_requires}
74 # goes into the -w3m subpackage
75 %{__cat} << \EOF
> README.fedora
76 See http
://ikiwiki.info
/w3mmode
/ for more information.
81 %{__perl} Makefile.PL INSTALLDIRS=vendor PREFIX=%{_prefix}
82 # parallel builds currently don't work
87 %{__rm} -rf %{buildroot}
88 %{__make} pure_install DESTDIR=%{buildroot} W3M_CGI_BIN=%{cgi_bin}
92 %{__rm} -rf %{buildroot}
95 %files -f
%{name}.lang
96 %defattr(-,root
,root
,-)
99 %{_mandir}/man1
/ikiwiki
*
100 %{_mandir}/man8
/ikiwiki
*
102 %dir %{_sysconfdir}/ikiwiki
103 %config(noreplace
) %{_sysconfdir}/ikiwiki
/*
104 # contains a packlist only
105 %exclude %{perl_vendorarch}
106 %{perl_vendorlib}/IkiWiki
*
107 %exclude %{perl_vendorlib}/IkiWiki
*/Plugin
/skeleton.pm.example
109 %doc README debian
/changelog debian
/NEWS html
110 %doc IkiWiki
/Plugin
/skeleton.pm.example
114 Summary: Ikiwiki w3m cgi meta
-wrapper
115 Group: Applications
/Internet
117 Requires: %{name} = %{version}-%{release}
120 Enable usage of all of ikiwiki's web features
(page editing
, etc
) in
121 the w3m web browser without a web server. w3m supports
local CGI
122 scripts
, and ikiwiki can be
set up to run that way using the
123 meta
-wrapper
in this package.
127 %defattr(-,root
,root
,-)
129 %{cgi_bin}/ikiwiki
-w3m.cgi