3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
12 IRTRANS_LIB_DIR
=/usr
/lib
/irtrans
/
14 DESTDIR
=$(CURDIR
)/debian
/tmp
18 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
24 configure
: configure-stamp
27 # Add here commands to configure the package.
31 #CFLAGS="$(CFLAGS)" ./configure --prefix=/usr --with-irtrans=$(IRTRANS_LIB_DIR)
32 CFLAGS
="$(CFLAGS)" .
/configure
--prefix=/usr
38 build-stamp
: configure-stamp
41 # Add here commands to compile the package.
43 #docbook-to-man debian/irtrans.sgml > irtrans.1
50 rm -f build-stamp configure-stamp
52 # Add here commands to clean up after the build process.
63 # Add here commands to install the package into debian/irtrans.
64 $(MAKE
) install DESTDIR
=$(DESTDIR
)
66 # These are in their own IRTrans package
67 #cp -v "../../../irtrans/trunk/irtransdll/libIRTrans.so" "./debian/tmp/usr/lib"
68 #cp -v "../../../irtrans/trunk/irserver/irserver" "./debian/tmp/usr/bin"
70 # Build architecture-independent files here.
71 binary-indep
: build
install
72 # We have nothing to do by default.
74 # Build architecture-dependent files here.
75 binary-arch
: build
install
78 # dh_installchangelogs ChangeLog
105 binary
: binary-indep binary-arch
106 .PHONY
: build
clean binary-indep binary-arch binary
install configure