Trunk cleanup: dummy
[irreco.git] / backend / irtrans / trunk / debian / rules
blob1662aa7eefcf607ec2f48162a26f1fa71e371fd0
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
12 IRTRANS_LIB_DIR=/usr/lib/irtrans/
14 DESTDIR=$(CURDIR)/debian/tmp
16 CFLAGS = -Wall -g
18 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19 CFLAGS += -O0
20 else
21 CFLAGS += -O2
22 endif
24 configure: configure-stamp
25 configure-stamp:
26 dh_testdir
27 # Add here commands to configure the package.
29 ./autogen.sh
31 #CFLAGS="$(CFLAGS)" ./configure --prefix=/usr --with-irtrans=$(IRTRANS_LIB_DIR)
32 CFLAGS="$(CFLAGS)" ./configure --prefix=/usr
33 touch configure-stamp
36 build: build-stamp
38 build-stamp: configure-stamp
39 dh_testdir
41 # Add here commands to compile the package.
42 $(MAKE)
43 #docbook-to-man debian/irtrans.sgml > irtrans.1
45 touch $@
47 clean:
48 dh_testdir
49 dh_testroot
50 rm -f build-stamp configure-stamp
52 # Add here commands to clean up after the build process.
53 -$(MAKE) clean
55 dh_clean
57 install: build
58 dh_testdir
59 dh_testroot
60 dh_clean -k
61 dh_installdirs
63 # Add here commands to install the package into debian/irtrans.
64 $(MAKE) install DESTDIR=$(DESTDIR)
66 # These are in their own IRTrans package
67 #cp -v "../../../irtrans/trunk/irtransdll/libIRTrans.so" "./debian/tmp/usr/lib"
68 #cp -v "../../../irtrans/trunk/irserver/irserver" "./debian/tmp/usr/bin"
70 # Build architecture-independent files here.
71 binary-indep: build install
72 # We have nothing to do by default.
74 # Build architecture-dependent files here.
75 binary-arch: build install
76 dh_testdir
77 dh_testroot
78 # dh_installchangelogs ChangeLog
79 # dh_installdocs
80 # dh_installexamples
81 # dh_install
82 # dh_installmenu
83 # dh_installdebconf
84 # dh_installlogrotate
85 # dh_installemacsen
86 # dh_installpam
87 # dh_installmime
88 # dh_python
89 # dh_installinit
90 # dh_installcron
91 # dh_installinfo
92 # dh_installman
93 dh_link
94 dh_strip
95 dh_compress
96 dh_fixperms
97 # dh_perl
98 # dh_makeshlibs
99 dh_installdeb
100 dh_shlibdeps
101 dh_gencontrol
102 dh_md5sums
103 dh_builddeb
105 binary: binary-indep binary-arch
106 .PHONY: build clean binary-indep binary-arch binary install configure