3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
14 export IRRECO_DEVELOPER
=yes
17 SET_PKG_CONFIG_PATH
= export PKG_CONFIG_PATH
=`readlink -f ./script/tmp`":$$PKG_CONFIG_PATH"
19 DESTDIR
=$(CURDIR
)/debian
/tmp
25 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
33 # Enable / disable pkg-config file installation.
34 # In other words, check dev flag
35 ifeq (,$(findstring yes
,$(IRRECO_DEVELOPER
)))
36 IRRECO_CONFIG
+= --enable-dev
=no
38 IRRECO_CONFIG
+= --enable-dev
=yes
42 # shared library versions, option 1
45 # option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
46 #version=`ls src/.libs/lib*.so.* | \
47 # awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
48 #major=`ls src/.libs/lib*.so.* | \
49 # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
51 configure
: configure-stamp
54 # Add here commands to configure the package.
59 CFLAGS
="$(CFLAGS)" .
/configure
--prefix=/usr
$(IRRECO_CONFIG
)
64 build-stamp
: configure-stamp
67 # Add here commands to compile the package.
68 # Add here commands to compile the package.
70 # $(MAKE) install DESTDIR=$(DESTDIR)
77 rm -f build-stamp configure-stamp
79 # Add here commands to clean up after the build process.
82 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
83 cp
-f
/usr
/share
/misc
/config.sub config.sub
85 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
86 cp
-f
/usr
/share
/misc
/config.guess config.guess
97 # Add here commands to install the package into debian/irreco.
98 # Actually installs to debian/tmp
99 #$(MAKE) DESTDIR=$(DESTDIR) install
101 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/tmp
102 # Build architecture-independent files here.
103 binary-indep
: build
install
104 # We have nothing to do by default.
106 # Build architecture-dependent files here.
107 binary-arch
: build
install
110 # dh_installchangelogs ChangeLog
113 dh_install
--sourcedir
=debian
/tmp
117 # dh_installlogrotate
138 binary
: binary-indep binary-arch
139 .PHONY
: build
clean binary-indep binary-arch binary
install configure