Mostly minor fixes up until version 0.8.10.
[irreco.git] / backend / telnet / debian / rules
blobcb0fecb26a312c29c71d4003ba21328cf3c42a53
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
15 CFLAGS = -Wall -g
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
27 ./autogen.sh
28 ./configure
29 touch configure-stamp
32 build: build-stamp
34 build-stamp: configure-stamp
35 dh_testdir
37 # Add here commands to compile the package.
38 $(MAKE)
39 #docbook-to-man debian/irreco-backend-telnet.sgml > irreco-backend-telnet.1
41 touch $@
43 clean:
44 dh_testdir
45 dh_testroot
46 rm -f build-stamp configure-stamp
48 # Add here commands to clean up after the build process.
49 -$(MAKE) clean
51 dh_clean
53 install: build
54 dh_testdir
55 dh_testroot
56 dh_clean -k
57 dh_installdirs
59 # Add here commands to install the package into debian/irreco-backend-telnet.
60 $(MAKE) DESTDIR=$(CURDIR)/debian/irreco-backend-telnet install
63 # Build architecture-independent files here.
64 binary-indep: build install
65 # We have nothing to do by default.
67 # Build architecture-dependent files here.
68 binary-arch: build install
69 dh_testdir
70 dh_testroot
71 dh_installchangelogs ChangeLog
72 dh_installdocs
73 dh_installexamples
74 # dh_install
75 # dh_installmenu
76 # dh_installdebconf
77 # dh_installlogrotate
78 # dh_installemacsen
79 # dh_installpam
80 # dh_installmime
81 # dh_python
82 # dh_installinit
83 # dh_installcron
84 # dh_installinfo
85 dh_installman
86 dh_link
87 dh_strip
88 dh_compress
89 dh_fixperms
90 # dh_perl
91 # dh_makeshlibs
92 dh_installdeb
93 dh_shlibdeps
94 dh_gencontrol
95 dh_md5sums
96 dh_builddeb
98 binary: binary-indep binary-arch
99 .PHONY: build clean binary-indep binary-arch binary install configure