Mostly minor fixes up until version 0.8.10.
[irreco.git] / irtrans / irserver / debian / rules
blob7b54bd1f95ee6ef2c37557456d1c0b61160e7483
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11 IRSERVER_SRC_DIR= ./src
16 CFLAGS = -Wall -g
18 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19 CFLAGS += -O0
20 else
21 CFLAGS += -O2
22 endif
24 configure: configure-stamp
25 configure-stamp:
26 dh_testdir
27 # Add here commands to configure the package.
29 touch configure-stamp
32 build: build-stamp
34 build-stamp: configure-stamp
35 dh_testdir
37 # Add here commands to compile the package.
38 #(MAKE)
39 cd $(IRSERVER_SRC_DIR) && make irservern800_noccf
40 #docbook-to-man debian/irtrans-irserver.sgml > irtrans-irserver.1
42 touch $@
44 clean:
45 dh_testdir
46 dh_testroot
47 rm -f build-stamp configure-stamp
49 # Add here commands to clean up after the build process.
51 cd $(IRSERVER_SRC_DIR) && make clean
52 dh_clean
54 install: build
55 dh_testdir
56 dh_testroot
57 dh_clean -k
58 dh_installdirs
60 # Add here commands to install the package into debian/irtrans-irserver.
61 #$(MAKE) DESTDIR=$(CURDIR)/debian/irtrans-irserver install
62 cd $(IRSERVER_SRC_DIR) && $(MAKE) install DESTDIR=$(CURDIR)/debian/irtrans-irserver
64 # Build architecture-independent files here.
65 binary-indep: build install
66 # We have nothing to do by default.
68 # Build architecture-dependent files here.
69 binary-arch: build install
70 dh_testdir
71 dh_testroot
72 dh_installchangelogs
73 dh_installdocs
74 dh_installexamples
75 # dh_install
76 # dh_installmenu
77 # dh_installdebconf
78 # dh_installlogrotate
79 # dh_installemacsen
80 # dh_installpam
81 # dh_installmime
82 # dh_python
83 # dh_installinit
84 # dh_installcron
85 # dh_installinfo
86 dh_installman
87 dh_link
88 dh_strip
89 dh_compress
90 dh_fixperms
91 # dh_perl
92 # dh_makeshlibs
93 dh_installdeb
94 dh_shlibdeps
95 dh_gencontrol
96 dh_md5sums
97 dh_builddeb
98 rm -f build-stamp install-stamp
99 rm -f configure-stamp
100 binary: binary-indep binary-arch
102 .PHONY: build clean binary-indep binary-arch binary install configure