3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
11 IRSERVER_SRC_DIR
= .
/src
18 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
24 configure
: configure-stamp
27 # Add here commands to configure the package.
34 build-stamp
: configure-stamp
37 # Add here commands to compile the package.
39 cd
$(IRSERVER_SRC_DIR
) && make irservern800_noccf
40 #docbook-to-man debian/irtrans-irserver.sgml > irtrans-irserver.1
47 rm -f build-stamp configure-stamp
49 # Add here commands to clean up after the build process.
51 cd
$(IRSERVER_SRC_DIR
) && make
clean
60 # Add here commands to install the package into debian/irtrans-irserver.
61 #$(MAKE) DESTDIR=$(CURDIR)/debian/irtrans-irserver install
62 cd
$(IRSERVER_SRC_DIR
) && $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/irtrans-irserver
64 # Build architecture-independent files here.
65 binary-indep
: build
install
66 # We have nothing to do by default.
68 # Build architecture-dependent files here.
69 binary-arch
: build
install
98 rm -f build-stamp install-stamp
100 binary
: binary-indep binary-arch
102 .PHONY
: build
clean binary-indep binary-arch binary
install configure