3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
11 IRTRANS_PKG_DIR
= .
/pkg
12 IRTRANS_SRC_DIR
= .
/src
17 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
23 # shared library versions, option 1
27 configure
: configure-stamp
30 # Add here commands to configure the package.
36 build-stamp
: configure-stamp
39 # Add here commands to compile the package.
40 cd
$(IRTRANS_SRC_DIR
) && make libIRTrans.so
48 rm -f build-stamp configure-stamp
50 # Add here commands to clean up after the build process.
61 # Add here commands to install the package into debian/tmp
62 #$(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
63 cp
$(IRTRANS_SRC_DIR
)/libIRTrans.so debian
/irtrans-shlib
/usr
/lib
/libIRTrans.so
64 cp
$(IRTRANS_PKG_DIR
)/*.
pc debian
/irtrans-shlib-dev
/usr
/lib
/pkgconfig
/
65 cp
$(IRTRANS_SRC_DIR
)/*.h debian
/irtrans-shlib-dev
/usr
/include/irtrans
/shlib
/
66 # Build architecture-independent files here.
67 binary-indep
: build
install
68 # We have nothing to do by default.
70 # Build architecture-dependent files here.
71 binary-arch
: build
install
74 # dh_installchangelogs
101 binary
: binary-indep binary-arch
102 .PHONY
: build
clean binary-indep binary-arch binary
install configure