Mostly minor fixes up until version 0.8.10.
[irreco.git] / irtrans / shlib / debian / rules
blob03843290997dd0b675f409485c98c7c91f49e80d
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11 IRTRANS_PKG_DIR= ./pkg
12 IRTRANS_SRC_DIR= ./src
15 CFLAGS = -Wall -g
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
23 # shared library versions, option 1
24 version=2.0.5
25 major=2
27 configure: configure-stamp
28 configure-stamp:
29 dh_testdir
30 # Add here commands to configure the package.
32 touch configure-stamp
35 build: build-stamp
36 build-stamp: configure-stamp
37 dh_testdir
39 # Add here commands to compile the package.
40 cd $(IRTRANS_SRC_DIR) && make libIRTrans.so
43 touch $@
45 clean:
46 dh_testdir
47 dh_testroot
48 rm -f build-stamp configure-stamp
50 # Add here commands to clean up after the build process.
53 dh_clean
55 install: build
56 dh_testdir
57 dh_testroot
58 dh_clean -k
59 dh_installdirs
61 # Add here commands to install the package into debian/tmp
62 #$(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
63 cp $(IRTRANS_SRC_DIR)/libIRTrans.so debian/irtrans-shlib/usr/lib/libIRTrans.so
64 cp $(IRTRANS_PKG_DIR)/*.pc debian/irtrans-shlib-dev/usr/lib/pkgconfig/
65 cp $(IRTRANS_SRC_DIR)/*.h debian/irtrans-shlib-dev/usr/include/irtrans/shlib/
66 # Build architecture-independent files here.
67 binary-indep: build install
68 # We have nothing to do by default.
70 # Build architecture-dependent files here.
71 binary-arch: build install
72 dh_testdir
73 dh_testroot
74 # dh_installchangelogs
75 # dh_installdocs
76 # dh_installexamples
77 # dh_install
78 # dh_installmenu
79 # dh_installdebconf
80 # dh_installlogrotate
81 # dh_installemacsen
82 # dh_installpam
83 # dh_installmime
84 # dh_installinit
85 # dh_installcron
86 # dh_installinfo
87 # dh_installman
88 dh_link
89 dh_strip
90 dh_compress
91 dh_fixperms
92 # dh_perl
93 # dh_python
94 # dh_makeshlibs
95 dh_installdeb
96 dh_shlibdeps
97 dh_gencontrol
98 dh_md5sums
99 dh_builddeb
101 binary: binary-indep binary-arch
102 .PHONY: build clean binary-indep binary-arch binary install configure