Merge branch 'master' of ssh://pege77@mercury.wipsl.com/var/git/irreco
[irreco.git] / backend / lirc / debian / rules
blob74708ef159279b37e83ea33434e3e52b29da8c11
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
14 DESTDIR=$(CURDIR)/debian/tmp
16 CFLAGS = -Wall -g
18 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19 CFLAGS += -O0
20 else
21 CFLAGS += -O2
22 endif
24 configure: configure-stamp
25 configure-stamp:
26 dh_testdir
27 # Add here commands to configure the package.
29 ./autogen.sh
31 #../../script/versioncheck.sh
33 CFLAGS="$(CFLAGS)" ./configure --prefix=/usr
35 touch configure-stamp
38 build: build-stamp
40 build-stamp: configure-stamp
41 dh_testdir
43 # Add here commands to compile the package.
44 $(MAKE)
45 #docbook-to-man debian/irreco-backend-lirc.sgml > irreco-backend-lirc.1
47 touch $@
49 clean:
50 dh_testdir
51 dh_testroot
52 rm -f build-stamp configure-stamp
54 # Add here commands to clean up after the build process.
55 -$(MAKE) clean
57 dh_clean
59 install: build
60 dh_testdir
61 dh_testroot
62 dh_clean -k
63 dh_installdirs
65 # Add here commands to install the package into debian/irreco-backend-lirc.
66 $(MAKE) install DESTDIR=$(DESTDIR)
69 # Build architecture-independent files here.
70 binary-indep: build install
71 # We have nothing to do by default.
73 # Build architecture-dependent files here.
74 binary-arch: build install
75 dh_testdir
76 dh_testroot
77 # dh_installchangelogs ChangeLog
78 # dh_installdocs
79 # dh_installexamples
80 # dh_install
81 # dh_installmenu
82 # dh_installdebconf
83 # dh_installlogrotate
84 # dh_installemacsen
85 # dh_installpam
86 # dh_installmime
87 # dh_python
88 # dh_installinit
89 # dh_installcron
90 # dh_installinfo
91 # dh_installman
92 dh_link
93 dh_strip
94 dh_compress
95 dh_fixperms
96 # dh_perl
97 # dh_makeshlibs
98 dh_installdeb
99 dh_shlibdeps
100 dh_gencontrol
101 dh_md5sums
102 dh_builddeb
104 binary: binary-indep binary-arch
105 .PHONY: build clean binary-indep binary-arch binary install configure