3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
14 DESTDIR
=$(CURDIR
)/debian
/tmp
18 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
24 configure
: configure-stamp
27 # Add here commands to configure the package.
31 #../../script/versioncheck.sh
33 CFLAGS
="$(CFLAGS)" .
/configure
--prefix=/usr
40 build-stamp
: configure-stamp
43 # Add here commands to compile the package.
45 #docbook-to-man debian/irreco-backend-lirc.sgml > irreco-backend-lirc.1
52 rm -f build-stamp configure-stamp
54 # Add here commands to clean up after the build process.
65 # Add here commands to install the package into debian/irreco-backend-lirc.
66 $(MAKE
) install DESTDIR
=$(DESTDIR
)
69 # Build architecture-independent files here.
70 binary-indep
: build
install
71 # We have nothing to do by default.
73 # Build architecture-dependent files here.
74 binary-arch
: build
install
77 # dh_installchangelogs ChangeLog
104 binary
: binary-indep binary-arch
105 .PHONY
: build
clean binary-indep binary-arch binary
install configure