1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 PYTHON_COMPAT=( python3_{6,7,8,9,10,11} )
7 PYTHON_REQ_USE='threads(+)'
9 inherit flag-o-matic python-single-r1 waf-utils xdg-utils
11 DESCRIPTION="LADI Session Handler - a session management system for JACK applications"
12 HOMEPAGE="https://ladish.org"
14 EGIT_REPO_URI="https://github.com/LADI/ladish.git"
15 EGIT_BRANCH="1-stable"
16 EGIT_COMMIT=7728d2d40e1c8eeb84b8605a411d9a83701d48b3
17 KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv x86"
24 IUSE="debug doc lash gtk"
25 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
27 RDEPEND="media-libs/alsa-lib
31 lash? ( !media-sound/lash )
37 >=dev-cpp/libgnomecanvasmm-2.6.0
41 doc? ( app-doc/doxygen )
42 >=media-sound/jack2-2.21.0
45 DOCS=( AUTHORS README.adoc NEWS )
52 append-cxxflags '-std=c++11'
57 local -a mywafconfargs=(
59 $(usex debug --debug '')
60 $(usex doc --doxygen '')
61 $(usex gtk '--enable-gladish' '')
62 $(usex lash '--enable-liblash' '')
64 waf-utils_src_configure "${mywafconfargs[@]}"
68 use doc && HTML_DOCS="${S}/build/default/html/*"