3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
16 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
19 ifeq (,$(findstring nostrip
,$(DEB_BUILD_OPTIONS
)))
23 config.status
: configure
26 find .
-type f
-name Makefile.am
-print |\
27 sed
's/\.am$$/.in/' |\
28 while read f
; do touch
"$$f"; done
;\
30 .
/configure
--host
=$(DEB_HOST_GNU_TYPE
) --build
=$(DEB_BUILD_GNU_TYPE
)\
31 --prefix=/usr
--mandir=\
$${prefix}/share
/man\
32 --infodir=\
$${prefix}/share
/info
36 build-stamp
: config.status
46 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
47 cp
-f
/usr
/share
/misc
/config.sub config.sub
49 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
50 cp
-f
/usr
/share
/misc
/config.guess config.guess
60 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/tmp
63 # Build architecture-independent files here.
64 binary-indep
: build
install
65 # We have nothing to do by default.
67 # Build architecture-dependent files here.
68 binary-arch
: build
install
71 dh_installchangelogs ChangeLog
73 dh_install
--sourcedir
=debian
/tmp
84 binary
: binary-indep binary-arch
85 .PHONY
: build
clean binary-indep binary-arch binary
install