1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "import distutils.sysconfig as d; print d.get_python_lib()")}
3 %define debug_package
%{nil}
5 Summary: Tools
for building live CD's
10 Group: System Environment
/Base
11 URL: http
://git.fedoraproject.org
/?p
=hosted
/livecd
12 Source0: %{name}-%{version}.tar.bz2
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17 Requires: yum
>= 3.1.7
19 Requires: squashfs
-tools
20 Requires: pykickstart
>= 0.96
21 Requires: dosfstools
>= 2.11-8
23 %ifarch %{ix86} x86_64
33 Tools
for generating live CD's on Fedora based systems including
34 derived distributions such as RHEL
, CentOS and others. See
35 http
://fedoraproject.org
/wiki
/FedoraLiveCD
for more details.
44 rm -rf $RPM_BUILD_ROOT
45 make install DESTDIR
=$RPM_BUILD_ROOT
48 rm -rf $RPM_BUILD_ROOT
51 %defattr(-,root
,root
,-)
52 %doc AUTHORS COPYING README HACKING
53 %{_bindir}/livecd
-creator
54 %{_bindir}/livecd
-iso
-to
-disk
55 %{_bindir}/livecd
-iso
-to
-pxeboot
56 %dir %{_datadir}/livecd
-tools
57 %{_datadir}/livecd
-tools
/*
58 %{_bindir}/image
-creator
59 %dir %{python_sitelib}/imgcreate
60 %{python_sitelib}/imgcreate
/*.py
61 %{python_sitelib}/imgcreate
/*.pyo
62 %{python_sitelib}/imgcreate
/*.pyc
65 * Tue May
6 2008 Bill Nottingham
<notting@redhat.com
> - 017-1
66 - fix F9 final configs
68 * Thu May
1 2008 Jeremy Katz
<katzj@redhat.com
> - 016-1
69 - Config changes all around
, including F9 final configs
70 - Fix up the minimal image creation
71 - Fix odd traceback error on __del__
(#442443)
72 - Add late initscript and split things
in half
73 - livecd
-iso
-to
-disk
: Check the available space on the stick
(#443046)
74 - Fix partition size overriding
(kanarip
)
76 * Thu Mar
6 2008 Jeremy Katz
<katzj@redhat.com
> - 015-1
77 - Support
for using live isos with pxe booting
(Richard W.M. Jones and
79 - Fixes
for SELinux being disabled
(Warren Togami
)
80 - Stop using mayflower
for building the initrd
; mkinitrd can
do it now
81 - Create a minimal
/dev rather than using the host
/dev
(Warren Togami
)
82 - Support
for persistent overlays when using a USB stick
(based on support
85 * Tue Feb
12 2008 Jeremy Katz
<katzj@redhat.com
> - 014-1
86 - Rework to provide a python API
for use by other tools
(thanks to
87 markmc
for a lot of the legwork here
)
88 - Fix creation of images with ext2 filesystems and no SELinux
89 - Don't require a yum
-cache directory inside of the cachedir
(#430066)
90 - Many config updates
for rawhide
91 - Allow running live images from MMC
/SD
(#430444)
92 - Don't
let a non
-standard TMPDIR
break things
(Jim Meyering
)
94 * Mon Oct
29 2007 Jeremy Katz
<katzj@redhat.com
> - 013-1
95 - Lots of config updates
96 - Support 'device foo' to say what modules go
in the initramfs
97 - Support multiple kernels being installed
98 - Allow blacklisting kernel modules on boot with blacklist
=foo
99 - Improve bootloader configs
100 - Split configs off
for f8
102 * Tue Sep
25 2007 Jeremy Katz
<katzj@redhat.com
> - 012-1
103 - Allow %
%post --nochroot to work
for putting files
in the root of the iso
104 - Set environment variables
for when %
%post is run
105 - Add progress
for downloads
(Colin Walters
)
106 - Add cachedir option
(Colin Walters
)
107 - Fixes
for ppc
/ppc64 to work again
108 - Clean up bootloader config a little
109 - Enable swaps
in the default desktop config
110 - Ensure all configs are installed
(#281911)
111 - Convert method line to a repo
for easier config reuse
(jkeating
)
112 - Kill the modprobe FATAL warnings
(#240585)
113 - Verify isos with iso
-to
-disk script
114 - Allow passing xdriver
for setting the xdriver
(#291281)
115 - Add turboliveinst patch
(Douglas McClendon
)
116 - Make iso
-to
-disk support
--resetmbr
(#294041)
117 - Clean up filesystem layout
(Douglas McClendon
)
118 - Manifest tweaks
for most configs
120 * Tue Aug
28 2007 Jeremy Katz
<katzj@redhat.com
> - 011-1
121 - Many config updates
for Fedora
8
122 - Support $basearch
in repo line of configs
; use it
123 - Support setting up Xen kernels and memtest86
+ in the bootloader config
125 - Improved default fs label
(Colin Walters
)
126 - Support localboot from the bootloader
(#252192)
127 - Use hidden menu support
in syslinux
128 - Have a base desktop config included by the other configs
(Colin Walters
)
129 - Use optparse
for optino parsing
130 - Remove a lot of
command line options
; things should be specified via the
131 kickstart config instead
132 - Beginnings of PPC support
(David Woodhouse
)
133 - Clean up kernel module inclusion to take advantage of files
in Fedora
134 kernels listing storage drivers
136 * Wed Jul
25 2007 Jeremy Katz
<katzj@redhat.com
> - 010-1
137 - Separate out configs used
for Fedora
7
138 - Add patch from Douglas McClendon to
make images smaller
139 - Add patch from Matt Domsch to work with older syslinux without vesamenu
140 - Add support
for using mirrorlists
; use them
141 - Let livecd
-iso
-to
-disk work with uncompressed images
(#248081)
142 - Raise error
if SELinux requested without being enabled
(#248080)
143 - Set service defaults on level
2 also
(#246350)
144 - Catch some failure cases
145 - Allow specifying tmpdir
146 - Add patch from nameserver specification from Elias Hunt
148 * Wed May
30 2007 Jeremy Katz
<katzj@redhat.com
> - 009-1
149 - miscellaneous live config changes
150 - fix isomd5 checking syntax error
152 * Fri May
4 2007 Jeremy Katz
<katzj@redhat.com
> - 008-1
153 - disable screensaver with default config
154 - add aic7xxx and sym53c8xx drivers to default initramfs
155 - fixes from johnp
for FC6 support
in the creator
156 - fix iso
-to
-stick to work on FC6
158 * Tue Apr
24 2007 Jeremy Katz
<katzj@redhat.com
> - 007-1
159 - Disable prelinking by default
160 - Disable some things that slow down the live boot substantially
161 - Lots of tweaks to the default package manifests
162 - Allow setting the root password
(Jeroen van Meeuwen
)
163 - Allow more specific network line setting
(Mark McLoughlin
)
164 - Don't pollute the host yum cache
(Mark McLoughlin
)
165 - Add support
for mediachecking
167 * Wed Apr
4 2007 Jeremy Katz
<katzj@redhat.com
> - 006-1
168 - Many fixes to error handling from Mark McLoughlin
170 - Add support
for prelinking
171 - Fixes
for installing when running from RAM or usb stick
172 - Add sanity checking to better ensure that USB stick is bootable
174 * Thu Mar
29 2007 Jeremy Katz
<katzj@redhat.com
> - 005-3
175 - have to use excludearch
, not exclusivearch
177 * Thu Mar
29 2007 Jeremy Katz
<katzj@redhat.com
> - 005-2
178 - exclusivearch since it only works on x86 and x86_64
for now
180 * Wed Mar
28 2007 Jeremy Katz
<katzj@redhat.com
> - 005-1
181 - some shell quoting fixes
182 - allow using UUID or LABEL
for the fs label of a usb stick
183 - work with ext2 formated usb stick
185 * Mon Mar
26 2007 Jeremy Katz
<katzj@redhat.com
> - 004-1
186 - add livecd
-iso
-to
-disk
for setting up the live CD iso image onto a usb
189 * Fri Mar
23 2007 Jeremy Katz
<katzj@redhat.com
> - 003-1
190 - fix remaining reference to run
-init
192 * Thu Mar
22 2007 Jeremy Katz
<katzj@redhat.com
> - 002-1
193 - update
for new version
195 * Fri Dec
22 2006 David Zeuthen
<davidz@redhat.com
> - 001-1%{?dist}