Run DCE after a LoopFlatten test to reduce spurious output [nfc]
[llvm-project.git] / clang / test / CXX / temp / temp.decls / temp.class.spec / p8-0x.cpp
blobe3726bd32fb236fe64fda957336e8072ec1fceac
1 // RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
2 // RUN: %clang_cc1 -fclang-abi-compat=15.0 -std=c++11 -fsyntax-only -verify %s
4 template<int ...Values> struct X1;
6 template<int ...Values> // expected-note {{non-deducible}}
7 struct X1<0, Values+1 ...>; // expected-error{{contains a template parameter that cannot be deduced}}
9 template<typename T, int ...Values> struct X2; // expected-note {{here}}
10 template<int ...Values> struct X2<X1<Values...>, Values+1 ...> {}; // ok (DR1315)
11 X2<X1<1, 2, 3>, 2, 3, 4> x2; // ok
12 X2<X1<1, 2, 3>, 2, 3, 4, 5> x3; // expected-error {{undefined template}}