Run DCE after a LoopFlatten test to reduce spurious output [nfc]
[llvm-project.git] / clang / test / CXX / temp / temp.decls / temp.class.spec / p9-0x.cpp
blobb754368600aa912a04d5e649e80bb6d05e2bd478
1 // RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
3 // -- The argument list of the specialization shall not be identical
4 // to the implicit argument list of the primary template.
6 template<typename T, typename ...Types>
7 struct X1;
9 template<typename T, typename ...Types>
10 struct X1<T, Types...> // expected-error{{class template partial specialization does not specialize any template argument; to define the primary template, remove the template argument list}}
11 { };