1 // RUN: %clang_cc1 -fsyntax-only -verify %s
3 template<typename T
, int N
>
18 // FIXME: We should produce diagnostics pointing out the
19 // non-matching candidates.
20 template<typename T
, int N
>
21 void A
<T
*, 2>::f0() { } // expected-error{{does not refer into a class, class template or class template partial specialization}}
23 template<typename T
, int N
>
24 void A
<T
, N
>::f1() { } // expected-error{{out-of-line definition}}