Run DCE after a LoopFlatten test to reduce spurious output [nfc]
[llvm-project.git] / clang / test / CXX / temp / temp.decls / temp.class.spec / temp.class.spec.mfunc / p1.cpp
blob184160ac78d1781da46a4b039beeb892805545c0
1 // RUN: %clang_cc1 -fsyntax-only -verify %s
2 // expected-no-diagnostics
3 template<typename T, int N>
4 struct A;
6 template<typename T>
7 struct A<T*, 2> {
8 A(T);
9 ~A();
11 void f(T*);
13 operator T*();
15 static T value;
18 template<class X> void A<X*, 2>::f(X*) { }
20 template<class X> X A<X*, 2>::value;
22 template<class X> A<X*, 2>::A(X) { value = 0; }
24 template<class X> A<X*, 2>::~A() { }
26 template<class X> A<X*, 2>::operator X*() { return 0; }