Run DCE after a LoopFlatten test to reduce spurious output [nfc]
[llvm-project.git] / clang / test / CXX / temp / temp.fct.spec / temp.arg.explicit / p1.cpp
blob0aef6adad13f2f753478d5b6647a8510413a3f5f
1 // RUN: %clang_cc1 -fsyntax-only %s
3 template<typename T> struct A { };
5 template<typename T> T make();
6 template<typename T> T make2(const T&);
8 void test_make() {
9 int& ir0 = make<int&>();
10 A<int> a0 = make< A<int> >();
11 A<int> a1 = make2< A<int> >(A<int>());