1 // RUN: %clang_cc1 -triple x86_64-apple-darwin -emit-llvm -o - %s | FileCheck %s
3 template<class T
> void f(T
) { /* ... */ }
4 template<class T
> inline void g(T
) { /* ... */ }
6 // CHECK: define{{.*}} void @_Z1gIiEvT_
7 template<> void g
<>(int) { /* ... */ }
21 inline void X
<T
>::h() {
24 // CHECK: define{{.*}} void @_ZN1XIiE1fEv
25 template<> void X
<int>::f() { }
27 // CHECK: define{{.*}} void @_ZN1XIiE1hEv
28 template<> void X
<int>::h() { }
30 // CHECK: define linkonce_odr void @_Z1fIiEvT_
31 template<> inline void f
<>(int) { /* ... */ }
33 // CHECK: define linkonce_odr void @_ZN1XIiE1gEv
34 template<> inline void X
<int>::g() { }
36 void test(X
<int> xi
) {