Run DCE after a LoopFlatten test to reduce spurious output [nfc]
[llvm-project.git] / clang / test / CXX / temp / temp.spec / temp.expl.spec / p20-2.cpp
blob7bc5f13cd7375bd695c9ba19a1c9a00b2bcf66fb
1 // RUN: %clang_cc1 -fsyntax-only -verify %s
2 template<typename T>
3 void f(T);
5 template<typename T>
6 struct A {
7 // expected-error@+1{{cannot declare an explicit specialization in a friend}}
8 template <> friend void f<>(int) {}
9 };
11 // Makes sure implicit instantiation here does not trigger
12 // the assertion "Member specialization must be an explicit specialization"
13 void foo(void) {
14 A<int> a;