1 // RUN: %clang_cc1 -fsyntax-only -verify %s
6 template<typename U
> void mf2(T
, U
); // expected-note{{previous}}
10 void X
<int>::mf1(int i
= 17) // expected-error{{default}}
15 void X
<int>::mf2(int, int = 17) // expected-error{{default}}
18 template<> template<typename U
>
19 void X
<int>::mf2(int, U
= U()) // expected-error{{default}}
28 void X
<float>::mf1(float = 3.14f
) // okay