Run DCE after a LoopFlatten test to reduce spurious output [nfc]
[llvm-project.git] / clang / test / CXX / temp / temp.spec / temp.expl.spec / p21.cpp
blobab26f407f3f38c04265db5d08220f495684a9295
1 // RUN: %clang_cc1 -fsyntax-only -verify %s
3 template<typename T>
4 struct X {
5 void mf1(T);
6 template<typename U> void mf2(T, U); // expected-note{{previous}}
7 };
9 template<>
10 void X<int>::mf1(int i = 17) // expected-error{{default}}
14 template<> template<>
15 void X<int>::mf2(int, int = 17) // expected-error{{default}}
16 { }
18 template<> template<typename U>
19 void X<int>::mf2(int, U = U()) // expected-error{{default}}
23 template<>
24 struct X<float> {
25 void mf1(float);
28 void X<float>::mf1(float = 3.14f) // okay