Run DCE after a LoopFlatten test to reduce spurious output [nfc]
[llvm-project.git] / clang / test / CXX / temp / temp.spec / temp.expl.spec / p3.cpp
blobca55c54a5e92b3e95663062fe3781f0a9b6bfb3e
1 // RUN: %clang_cc1 -fsyntax-only -verify %s
2 // RUN: %clang_cc1 -fsyntax-only -verify -std=c++98 %s
3 // RUN: %clang_cc1 -fsyntax-only -verify -std=c++11 %s
5 namespace N {
6 template<class T> class X; // expected-note {{'N::X' declared here}}
9 template<> class X<int> { /* ... */ }; // expected-error {{no template named 'X'; did you mean 'N::X'?}}
11 namespace N {
13 template<> class X<char*> { /* ... */ }; // OK: X is a template