Run DCE after a LoopFlatten test to reduce spurious output [nfc]
[llvm-project.git] / clang / test / CXX / temp / temp.spec / temp.expl.spec / p9.cpp
blob10ec66d53994a90e11dbdb9c8e7453ba623becce
1 // RUN: %clang_cc1 -fsyntax-only -verify %s
2 // expected-no-diagnostics
4 namespace N {
5 template<class T> class X { /* ... */ };
6 template<class T> class Y { /* ... */ };
7 template<> class X<int> { /* ... */ };
8 template<> class Y<double>;
10 const unsigned NumElements = 17;
13 template<> class N::Y<double> {
14 int array[NumElements];