1 // RUN: %clang_cc1 -fsyntax-only -std=c++11 -verify %s
8 template inline void X
<int>::f(); // expected-error{{explicit instantiation cannot be 'inline'}}
12 constexpr int f() { return 0; } // expected-warning{{C++14}}
15 template constexpr int Y
<int>::f() const; // expected-error{{explicit instantiation cannot be 'constexpr'}}
19 enum E
: T
{ e1
, e2
};
20 T t
; // expected-note {{refers here}}
23 template enum Z
<int>::E
; // expected-error {{enumerations cannot be explicitly instantiated}}
24 template int Z
<int>::t
; // expected-error {{explicit instantiation of 't' does not refer to}}