1 // RUN: %clang_cc1 -fsyntax-only -verify %s
14 t
= 1; // expected-error{{incompatible integer to pointer conversion}}
23 T X0
<T
>::static_var
= 1; // expected-error{{cannot initialize}}
25 extern template struct X0
<void*>;
26 template struct X0
<void*>; // expected-note 2{{instantiation}}
28 template struct X0
<int>; // expected-note 4{{explicit instantiation definition is here}}
30 extern template void X0
<int>::f(int&); // expected-error{{follows explicit instantiation definition}}
31 extern template struct X0
<int>::Inner
; // expected-error{{follows explicit instantiation definition}}
32 extern template int X0
<int>::static_var
; // expected-error{{follows explicit instantiation definition}}
33 extern template struct X0
<int>; // expected-error{{follows explicit instantiation definition}}