1 // RUN: %clang_cc1 -fsyntax-only -std=c++11 -verify %s
6 t
= 1; // expected-error{{incompatible integer to pointer conversion}}
17 inline void X0
<T
>::g(T
& t
) {
18 t
= 1; // expected-error{{incompatible integer to pointer conversion}}
22 void X0
<T
>::h(T
& t
) {
27 T X0
<T
>::static_var
= 1;
29 extern template struct X0
<int*>;
31 int *&test(X0
<int*> xi
, int *ip
) {
32 xi
.f(ip
); // expected-note{{instantiation}}
33 xi
.g(ip
); // expected-note{{instantiation}}
35 return X0
<int*>::static_var
;
40 t
= 1; // expected-error{{incompatible integer to pointer conversion}}
44 inline void f1(T
& t
) {
45 t
= 1; // expected-error 2{{incompatible integer to pointer conversion}}
48 extern template void f0
<>(int *&);
49 extern template void f1
<>(int *&);
51 void test_f0(int *ip
, float *fp
) {
53 f0(fp
); // expected-note{{instantiation}}
56 void test_f1(int *ip
, float *fp
) {
57 f1(ip
); // expected-note{{instantiation}}
58 f1(fp
); // expected-note{{instantiation}}