[mlir][acc] Introduce MappableType interface (#122146)
[llvm-project.git] / clang / test / CXX / dcl.dcl / dcl.spec / dcl.fct.spec / p3.cpp
blobd7b9eff10a8086256be3f6e9193d493eb7509273
1 // RUN: %clang_cc1 -verify %s
3 void f0a(void) {
4 inline void f1(); // expected-error {{inline declaration of 'f1' not allowed in block scope}}
7 void f0b(void) {
8 void f1();
11 // FIXME: Add test for "If the inline specifier is used in a friend declaration,
12 // that declaration shall be a definition or the function shall have previously
13 // been declared inline.