[RISCV][VLOPT] Rename vx to vf where appropriate in test case
[llvm-project.git] / clang / test / CXX / dcl.dcl / dcl.spec / dcl.stc / p9.cpp
blob491ab17802e06328677271545d36b8cc6cb48b75
1 // RUN: %clang_cc1 -verify %s
3 struct S; // expected-note 2{{forward declaration of 'S'}}
4 extern S a;
5 extern S f(); // expected-note {{'f' declared here}}
6 extern void g(S a);
8 void h() {
9 g(a); // expected-error {{argument type 'S' is incomplete}}
10 f(); // expected-error {{calling 'f' with incomplete return type 'S'}}