1 // RUN: %clang_cc1 -fsyntax-only -verify %s
2 // expected-no-diagnostics
8 // If A is a cv-qualified type, the top level cv-qualifiers of A's type
9 // are ignored for type deduction.
10 void test_cvquals(AnyPtr ap
) {
12 const float * const volatile fp
= ap
;
15 // If A is a reference type, the type referred to by A is used for
17 void test_ref_arg(AnyPtr ap
) {
18 const int* const &ip
= ap
;
19 double * const &dp
= ap
;
27 void test_ref_param(AnyRef ar
) {