repo.or.cz
/
llvm-project.git
/
blob
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
log
|
graphiclog1
|
graphiclog2
|
commit
|
commitdiff
|
tree
|
refs
|
edit
|
fork
blame
|
history
|
raw
|
HEAD
[compiler-rt] Add weak defs for .*contiguous_container.* functions (#120376)
[llvm-project.git]
/
clang
/
test
/
CXX
/
temp
/
temp.fct.spec
/
temp.deduct
/
temp.deduct.partial
/
p9-0x.cpp
blob
cc129c0a9b2eff5ae34990360105a4f323cda38d
1
// RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
2
// expected-no-diagnostics
3
4
template
<
typename T
>
int
&
f0
(
T
&);
5
template
<
typename T
>
float
&
f0
(
T
&&);
6
7
// Core issue 1164
8
void
test_f0
(
int
i
) {
9
int
&
ir0
=
f0
(
i
);
10
float
&
fr0
=
f0
(
5
);
11
}