1 // RUN: %clang_cc1 --std=c++1y -fsyntax-only -verify %s
3 // RUN: not %clang_cc1 --std=c++1y -x c++ -fixit %t -DFIXING
4 // RUN: %clang_cc1 --std=c++1y -x c++ %t -DFIXING
7 T pi
= T(3.1415926535897932385); // expected-note {{template is declared here}}
12 template float pi
<>; // expected-error {{too few template arguments for variable template 'pi'}}
13 template double pi_var0
; // expected-error {{explicit instantiation of 'pi_var0' does not refer to a function template, variable template, member function, member class, or static data member}}
16 // Should recover as if definition
17 template double pi_var
= 5; // expected-error {{variable cannot be defined in an explicit instantiation; if this declaration is meant to be a variable definition, remove the 'template' keyword}}
20 T pi0
= T(3.1415926535897932385); // expected-note {{previous definition is here}}
22 template int pi0
= 10; // expected-error {{variable cannot be defined in an explicit instantiation; if this declaration is meant to be a variable definition, remove the 'template' keyword}} \
23 expected
-error
{{redefinition of
'pi0' as different kind of symbol
}}
27 T pi1
= T(3.1415926535897932385); // expected-note 0-2 {{here}}
29 // Should recover as if specialization
30 template float pi1
<float> = 1.0; // expected-error {{explicit template instantiation cannot have a definition; if this definition is meant to be an explicit specialization, add '<>' after the 'template' keyword}}
31 namespace expected_global
{
33 template int pi1
<int> = 10; // expected-error {{explicit template instantiation cannot have a definition; if this definition is meant to be an explicit specialization, add '<>' after the 'template' keyword}} expected-error {{must occur at global scope}}