repo.or.cz
/
llvm-project.git
/
blob
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
log
|
graphiclog1
|
graphiclog2
|
commit
|
commitdiff
|
tree
|
refs
|
edit
|
fork
blame
|
history
|
raw
|
HEAD
[SLP]Propagate AssumptionCache where possible
[llvm-project.git]
/
clang
/
test
/
CXX
/
temp
/
temp.spec
/
temp.expl.spec
/
p10.cpp
blob
b81c1e7b2c8fd09cd0c555c12751283f66f309ab
1
// RUN: %clang_cc1 -fsyntax-only -verify %s
2
3
template
<
class
T
>
class
X
;
4
template
<>
class
X
<
int
>;
// expected-note{{forward}}
5
X
<
int
>*
p
;
6
7
X
<
int
>
x
;
// expected-error{{incomplete type}}