1 // RUN: %clang_cc1 -fsyntax-only -verify %s
6 T member
; // expected-error{{with function type}}
10 return ptr
+ 1; // expected-error{{pointer to the function}}
13 static T
* static_member
;
17 T
* X0
<T
>::static_member
= ((T
*)0) + 1; // expected-error{{pointer to the function}}
19 template class X0
<int>; // okay
21 template class X0
<int(int)>; // expected-note 3{{requested here}}
23 // Specialize everything, so that the explicit instantiation does not trigger
26 struct X0
<int(long)>::MemberClass
{ };
28 typedef int int_long_func(long);
30 int_long_func
*X0
<int_long_func
>::f0(int_long_func
*) { return 0; }
33 int_long_func
*X0
<int(long)>::static_member
;
35 template class X0
<int(long)>;