[CI] Detect step failures in metrics job (#122564)
[llvm-project.git] / clang / test / CXX / temp / temp.spec / temp.inst / p11.cpp
blobb568b60cbd3f856752425a45985b545f0209eb44
1 // RUN: %clang_cc1 -verify -emit-llvm-only %s
3 namespace test0 {
4 template<typename T> unsigned f0() {
5 return T::MaxSize; // expected-error {{'int' cannot be used prior to '::'}}
6 };
7 template<typename T> struct A {
8 void Allocate(unsigned Alignment
9 = f0<T>()) // expected-note {{in instantiation}}
12 void f1(A<int> x) { x.Allocate(); }