1 // RUN: %clang_cc1 -verify -emit-llvm-only %s
4 template<typename T
> unsigned f0() {
5 return T::MaxSize
; // expected-error {{'int' cannot be used prior to '::'}}
7 template<typename T
> struct A
{
8 void Allocate(unsigned Alignment
9 = f0
<T
>()) // expected-note {{in instantiation}}
12 void f1(A
<int> x
) { x
.Allocate(); }