1 // RUN: %clang_cc1 -fexceptions -fcxx-exceptions -fsyntax-only -verify %s
8 friend void f() noexcept
;
9 friend void g() noexcept(x
);
11 static constexpr bool x
= true;
21 friend void f() noexcept
;
22 // FIXME: This error is emitted if no other errors occured (i.e. Sema::hasUncompilableErrorOccurred() is false).
23 friend void g() noexcept(x
); // expected-error {{no member 'x' in 'N1::A<int>'; it has not yet been instantiated}}
24 // expected-note@-1 {{in instantiation of exception specification}}
25 static constexpr bool x
= false; // expected-note {{not-yet-instantiated member is declared here}}
28 template struct A
<int>; // expected-note {{in instantiation of template class}}