3 # We deduce the target based on the available version of the Maemo SDK
4 ifeq (1,$(shell pkg-config
--atleast-version
=5 maemo-version
&& echo
1))
10 CONFIGURE_OPTIONS
:= --target
=$(TARGET
) --ram
=8 --rbdir
=/.rockbox
--type
=N
11 DESKTOP_DIR
:= `pkg-config --variable=desktopentrydir osso-af-settings`
16 test -d builddir || mkdir
-p builddir
18 builddir
/Makefile
: builddir
19 cd builddir
&& test -f Makefile || ..
/tools
/configure
$(CONFIGURE_OPTIONS
)
23 build-stamp
: builddir
/Makefile
25 cd builddir
&& $(MAKE
)
40 cd builddir
&& $(MAKE
) PREFIX
=$(CURDIR
)/debian
/rockbox
/opt
/rockbox fullinstall
42 # Remove broken plugins (keymap missing)
43 # Note: Credits and f.e. mikmod are included and working
44 rm -f
$(CURDIR
)/debian
/rockbox
/opt
/rockbox
/lib
/rockbox
/rocks
/apps
/*
45 rm -f
$(CURDIR
)/debian
/rockbox
/opt
/rockbox
/lib
/rockbox
/rocks
/demos
/*
46 rm -f
$(CURDIR
)/debian
/rockbox
/opt
/rockbox
/lib
/rockbox
/rocks
/games
/*
48 # Install icon and .desktop file
49 mkdir
-p
$(CURDIR
)/debian
/rockbox
/usr
/share
/icons
/hicolor
/64x64
/apps
50 cp
-f debian
/maemo
/rockbox.png
$(CURDIR
)/debian
/rockbox
/usr
/share
/icons
/hicolor
/64x64
/apps
51 mkdir
-p
$(CURDIR
)/debian
/rockbox
$(DESKTOP_DIR
)
52 cp
-f debian
/maemo
/rockbox.desktop
$(CURDIR
)/debian
/rockbox
$(DESKTOP_DIR
)
54 # Ignore built in sounds
55 mkdir
-p
$(CURDIR
)/debian
/rockbox
/usr
/share
/sounds
56 touch
$(CURDIR
)/debian
/rockbox
/usr
/share
/sounds
/database.ignore
58 # Build architecture-independent files here.
60 # We have nothing to do by default.
62 # Build architecture-dependent files here.
63 binary-arch
: build
install
70 dh_strip
--dbg-package
=rockbox-dbg
79 binary
: binary-indep binary-arch
80 .PHONY
: build
clean binary-indep binary-arch binary
install configure