3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
10 # These are used for cross-compiling and for saving the configure script
11 # from having to guess our platform (since we know it already)
12 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
13 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
19 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
24 ifeq (,$(findstring nostrip
,$(DEB_BUILD_OPTIONS
)))
28 config.status
: configure
30 # Add here commands to configure the package.
31 CFLAGS
="$(CFLAGS)" .
/configure
--host
=$(DEB_HOST_GNU_TYPE
) --build
=$(DEB_BUILD_GNU_TYPE
) --prefix=/usr
--mandir=\
$${prefix}/share
/man
--infodir=\
$${prefix}/share
/info
36 build-stamp
: config.status
39 # Add here commands to compile the package.
48 # Add here commands to clean up after the build process.
59 # Add here commands to install the package into debian/maepad
60 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/maepad
63 # Build architecture-independent files here.
64 binary-indep
: build
install
65 # We have nothing to do by default.
67 # Build architecture-dependent files here.
68 binary-arch
: build
install
82 binary
: binary-indep binary-arch
83 .PHONY
: build
clean binary-indep binary-arch binary
install