7 GLX_MESA_pixmap_colormap
11 Brian Paul
(brian.paul 'at' tungstengraphics.com
)
15 Shipping since Mesa
1.2.8 in May
, 1996.
19 Last Modified Date
: 8 June
2000
27 OpenGL
1.0 or later is required.
28 GLX
1.0 or later is required.
32 Since Mesa allows RGB rendering into drawables with PseudoColor
,
33 StaticColor
, GrayScale and StaticGray visuals
, Mesa needs a colormap
34 in order to compute pixel values during rendering.
36 The colormap associated with a window can be queried with normal
37 Xlib functions but there is no colormap associated with pixmaps.
39 The glXCreateGLXPixmapMESA
function is an alternative to glXCreateGLXPixmap
40 which allows specification of a colormap.
44 Open
-source; freely implementable.
50 New Procedures and Functions
52 GLXPixmap glXCreateGLXPixmapMESA
( Display
*dpy
, XVisualInfo
*visual
,
53 Pixmap pixmap
, Colormap cmap
);
59 Additions to Chapter
3 of the GLX
1.3 Specification
(Functions and Errors
)
61 Add to section
3.4.2 Off Screen Rendering
63 The Mesa implementation of GLX allows RGB rendering into X windows and
64 pixmaps of any visual class
, not just TrueColor or DirectColor. In order
65 to compute pixel values from RGB values Mesa requires a colormap.
69 GLXPixmap glXCreateGLXPixmapMESA
( Display
*dpy
, XVisualInfo
*visual
,
70 Pixmap pixmap
, Colormap cmap
);
72 allows one to create a GLXPixmap with a specific colormap. The image
73 rendered into the pixmap may
then be copied to a window
(which uses the
74 same colormap and visual
) with the expected results.
78 None since this is a client
-side extension.
90 8 June
2000 - initial specification