7 GLX_MESA_release_buffers
11 Brian Paul
(brian.paul 'at' tungstengraphics.com
)
15 Shipping since Mesa
2.0 in October
, 1996.
19 Last Modified Date
: 8 June
2000
27 OpenGL
1.0 or later is required.
28 GLX
1.0 or later is required.
32 Mesa's implementation of GLX is entirely implemented on the client side.
33 Therefore
, Mesa cannot immediately detect when an X window or pixmap is
34 destroyed
in order to free any ancilliary data associated with the window
37 The glxMesaReleaseBuffers
() function can be used to explicitly indicate
38 when the back color buffer
, depth buffer
, stencil buffer
, and
/or accum
-
39 ulation buffer associated with a drawable can be freed.
43 Open
-source; freely implementable.
49 New Procedures and Functions
51 Bool glXReleaseBuffersMESA
( Display
*dpy
, GLXDrawable d
);
57 Additions to Chapter
3 of the GLX
1.3 Specification
(Functions and Errors
)
61 Bool glXReleaseBuffersMESA
( Display
*dpy
, GLXDrawable d
);
63 causes all software ancilliary buffers
(back buffer
, depth
, stencil
,
64 accum
, etc
) associated with the named drawable to be immediately
65 deallocated. True is returned
if <d
> is a valid Mesa GLX drawable
,
66 else False is returned. After calling glXReleaseBuffersMESA
, the
67 drawable should no longer be used
for GL rendering. Results of
68 attempting to
do so are undefined.
73 None
, since this is a client
-side operation.
85 8 June
2000 - initial specification