glsl2: Set a flag when visiting the assignee of an assignment
[mesa/nouveau-pmpeg.git] / docs / MESA_resize_buffers.spec
blob533d017c9a91270febb18a201862c8d2b057dfab
1 Name
3 MESA_resize_buffers
5 Name Strings
7 GL_MESA_resize_buffers
9 Contact
11 Brian Paul (brian.paul 'at' tungstengraphics.com)
13 Status
15 Shipping (since Mesa version 2.2)
17 Version
20 Number
22 196
24 Dependencies
26 Mesa 2.2 or later is required.
28 Overview
30 Mesa is often used as a client library with no integration with
31 the computer's window system (an X server, for example). And since
32 Mesa does not have an event loop nor window system callbacks, it
33 cannot properly respond to window system events. In particular,
34 Mesa cannot automatically detect when a window has been resized.
36 Mesa's glViewport command queries the current window size and updates
37 its internal data structors accordingly. This normally works fine
38 since most applications call glViewport in responce to window size
39 changes.
41 In some situations, however, the application may not call glViewport
42 when a window size changes but would still like Mesa to adjust to
43 the new window size. This extension exports a new function to solve
44 this problem.
46 New Procedures and Functions
48 void glResizeBuffersMESA( void )
50 New Tokens
52 none
54 Additions to the OpenGL Specification (no particular section)
56 The glResizeBuffersMESA command may be called when the client
57 determines that a window has been resized. Calling
58 glResizeBuffersMESA causes Mesa to query the current window size
59 and adjust its internal data structures. This may include
60 reallocating depth, stencil, alpha and accumulation buffers.
62 Additions to the AGL/GLX/WGL Specifications
64 None
66 Errors
68 INVALID_OPERATION is generated if ResizeBuffersMESA is called betweeen
69 Begin and End.
71 New State
73 None.
75 New Implementation Dependent State
77 None.
79 Revision History
81 * Revision 1.0 - Initial specification