2 # MAde with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Cristoph Lameter.
6 # Uncomment this to turn on verbose mode.
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
12 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
16 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
21 ifeq (,$(findstring nostrip
,$(DEB_BUILD_OPTIONS
)))
26 configure
: configure-stamp
30 CFLAGS
="$(CFLAGS)" .
/configure \
31 --host
=$(DEB_HOST_GNU_TYPE
) \
32 --build
=$(DEB_BUILD_GNU_TYPE
) \
34 --mandir=\
$${prefix}/share
/man \
36 --program-transform-name
='s,^,b,'
41 build-stamp
: configure-stamp
52 [ ! -f Makefile
] ||
$(MAKE
) clean
54 rm -f configure-stamp build-stamp install-stamp \
55 config.cache config.h config.status config.log makefile
61 install: install-stamp
62 install-stamp
: build-stamp
68 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/byacc
72 # Build architecture-independent files here.
73 binary-indep
: build
install
74 # No binary-indep target.
76 # Build architecture-dependent files here.
77 binary-arch
: build
install
82 dh_installchangelogs CHANGES
92 binary
: binary-indep binary-arch
93 .PHONY
: build
clean binary-indep binary-arch binary
install install-stamp