1 Summary: The Internet Systems Consortium
(ISC
) DHCP server
6 Group: System Environment
/Daemons
7 Source: /usr
/local/src
/RPM
/SOURCES
/dhcp
-%{version}.tar.gz
9 BuildRoot: /var
/tmp
/dhcp
-%{version}-root
12 Dhcp includes the DHCP server which is used
for dynamically configuring
13 hosts on a network. Host configuration items such as IP address
, name
14 servers
, domain name
, etc. can all be retrieved from the DHCP server by
15 a DHCP client. This eases the burden of network wide configuration by
16 putting all of the configuration into one place.
19 Summary: A DHCP client
20 Group: System Environment
/Configuration
23 Dhcp client is a DHCP client
for various UNIX operating systems. It allows
24 a UNIX machine to obtain it's networking parameters from a DHCP server.
28 Group: System Environment
/Daemons
31 Dhcp relay is a relay agent
for DHCP packets. It is used on a subnet with
32 DHCP clients to "relay" their requests to a subnet that has a DHCP server
33 on it. Because DHCP packets can be broadcast
, they will not be routed off
34 of the
local subnet. The DHCP relay takes care of this
for the client.
37 Summary: Development headers and libraries
for the dhcpctl API
38 Group: Development
/Libraries
41 Dhcp devel contains all of the libraries and headers
for developing with
45 %setup -q
-n dhcp
-%{version}
46 # do some file editing
49 VARDB" site.conf | sed
-e 's
/ *=/=/g'
-e 's
/= */=/g'
> vars
51 cat
<< EOF
>> includes
/site.h
52 #define _PATH_DHCPD_PID "$VARRUN/dhcpd.pid"
53 #define _PATH_DHCPD_DB "$ETC/dhcpd.leases"
54 #define _PATH_DHCPD_CONF "$ETC/dhcpd.conf"
56 .
/configure
--with
-nsupdate
62 rm -rf $RPM_BUILD_ROOT
63 mkdir -p $RPM_BUILD_ROOT
/usr
/local/sbin
65 make DESTDIR
="$RPM_BUILD_ROOT"
install
68 mkdir -p $
{RPM_BUILD_ROOT
}/etc
/rc.d
/{init
,rc0
,rc1
,rc2
,rc3
,rc4
,rc5
,rc6
}.d
69 install -m
755 linux.init $
{RPM_BUILD_ROOT
}/etc
/rc.d
/init.d
/dhcpd
72 mkdir -p $
{RPM_BUILD_ROOT
}/etc
/init.d
73 sed
-e s'|@PREFIX@|
%{_prefix}|g' < contrib/solaris.init > ${RPM_BUILD_ROOT}/etc
/init.d
/dhcpd
74 chmod
755 $
{RPM_BUILD_ROOT
}/etc
/init.d
/dhcpd
78 # strip binaries and libraries
79 strip $RPM_BUILD_ROOT
%{_prefix}/sbin
/* ||
:
80 for i
in `find $RPM_BUILD_ROOT
/ -type 'f'
-perm '
+a
=x'
! -name 'lib
*so
*'`
; do
81 file $i |grep
-q "not stripped"
&& strip $i
86 /sbin
/chkconfig
--add dhcpd
87 /etc
/rc.d
/init.d
/dhcpd start
90 ln
/etc
/init.d
/dhcpd
/etc
/rc2.d
/S90dhcpd
91 ln
/etc
/init.d
/dhcpd
/etc
/rc0.d
/K30dhcpd
92 /etc
/init.d
/dhcpd start
94 echo "Unknown O
/S. You will need to manually configure your\nsystem"
95 echo "to start the DHCP server on system startup."
102 /etc
/rc.d
/init.d
/dhcpd stop
103 /sbin
/chkconfig
--del dhcpd
106 /etc
/init.d
/dhcpd stop
107 rm /etc
/rc2.d
/S90dhcpd
108 rm /etc
/rc0.d
/K30dhcpd
110 echo "Unknown O
/S. You will need to manually clean up the DHCP"
111 echo "server startup\n
in your system startup environment."
117 rm -rf $RPM_BUILD_ROOT
120 %defattr(-,root
,root
)
121 %doc COPYRIGHT DOCUMENTATION ISC
-LICENSE CHANGES README RELNOTES doc
/*
123 %{_prefix}/sbin
/dhcpd
124 %{_prefix}/man
/cat1m
/dhcpd
.1m
125 %{_prefix}/man
/cat4
/dhcpd.conf
.4
126 %{_prefix}/man
/cat4
/dhcpd.leases
.4
127 %{_prefix}/man
/cat4
/dhcp
-options
.4
128 %{_prefix}/man
/cat4
/dhcp
-eval.4
129 %{_prefix}/man
/cat4
/dhcp
-contrib
.4
131 %config /etc
/rc.d
/init.d
/dhcpd
134 %config /etc
/init.d
/dhcpd
144 %{_prefix}/etc
/dhclient
-script
145 %{_prefix}/sbin
/dhclient
146 %{_prefix}/man
/cat1m
/dhclient
.1m
147 %{_prefix}/man
/cat1m
/dhclient
-script
.1m
148 %{_prefix}/man
/cat4
/dhclient.conf
.4
149 %{_prefix}/man
/cat4
/dhclient.leases
.4
152 %{_prefix}/sbin
/dhcrelay
153 %{_prefix}/man
/cat1m
/dhcrelay
.1m
156 * Fri Oct
1 1999 Brian J. Murrell
<brian@interlinx.bc.ca
>
157 - write a spec file
for dhcpd