1 Summary: byacc
- public domain Berkeley LALR Yacc parser generator
2 %define AppProgram byacc
3 %define AppVersion
20130304
4 %define UseProgram yacc
5 # $XTermId: byacc.spec,v 1.16 2013/03/05 01:17:35 tom Exp $
9 License: Public Domain
, MIT
10 Group: Applications
/Development
11 URL: ftp
://invisible
-island.net
/%{AppProgram}
12 Source0: %{AppProgram}-%{AppVersion}.tgz
13 Packager: Thomas Dickey
<dickey@invisible
-island.net
>
16 This package provides a parser generator utility that reads a grammar
17 specification from a file and generates an LR
(1) parser
for it. The
18 parsers consist of a
set of LALR
(1) parsing tables and a driver
19 routine written
in the C programming language. It has a public domain
20 license which includes the generated C.
24 %setup -q
-n
%{AppProgram}-%{AppVersion}
28 INSTALL_PROGRAM
='$
{INSTALL
}' \
31 --target
%{_target_platform} \
40 [ "$RPM_BUILD_ROOT"
!= "
/"
] && rm -rf $RPM_BUILD_ROOT
42 make install DESTDIR
=$RPM_BUILD_ROOT
43 ( cd $RPM_BUILD_ROOT
%{_bindir} && ln -s %{AppProgram} %{UseProgram} )
45 strip $RPM_BUILD_ROOT
%{_bindir}/%{AppProgram}
48 [ "$RPM_BUILD_ROOT"
!= "
/"
] && rm -rf $RPM_BUILD_ROOT
52 %{_prefix}/bin/%{AppProgram}
53 %{_prefix}/bin/%{UseProgram}
54 %{_mandir}/man1/%{AppProgram}.
*
57 # each patch should add its ChangeLog entries here
59 * Sun Jun
06 2010 Thomas Dickey