1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools multilib git-2
8 DESCRIPTION
="A ncurses client for the Music Player Daemon (MPD)"
9 HOMEPAGE
="http://mpd.wikia.com/wiki/Client:Ncmpc"
10 EGIT_REPO_URI
="git://git.musicpd.org/cirrus/ncmpc.git"
11 EGIT_BOOTSTRAP
="eautoreconf"
16 IUSE
="artist-screen colors debug +help-screen key-screen lirc lyrics-screen mouse nls search-screen song-screen"
18 RDEPEND
=">=dev-libs/glib-2.12:2
19 ~media-libs/libmpdclient-9999
21 lirc? ( app-misc/lirc )
22 nls? ( sys-libs/ncurses[unicode] )"
26 DOCS
=( AUTHORS NEWS README
doc
/config.sample
doc
/keys.sample
)
29 # upstream lirc doesn't have pkg-config file wrt #250015
31 export LIBLIRCCLIENT_CFLAGS
="-I/usr/include/lirc"
32 export LIBLIRCCLIENT_LIBS
="-llirc_client"
35 # use_with lyrics-screen is for multilib
37 --docdir=/usr
/share
/doc
/${PF} \
38 $
(use_enable nls multibyte
) \
39 $
(use_enable nls locale
) \
41 $
(use_enable colors
) \
43 $
(use_enable help-screen
) \
45 $
(use_enable artist-screen
) \
46 $
(use_enable search-screen
) \
47 $
(use_enable song-screen
) \
48 $
(use_enable key-screen
) \
49 $
(use_enable lyrics-screen
) \
51 $
(use_with lyrics-screen lyrics-plugin-dir
/usr
/$
(get_libdir
)/ncmpc
/lyrics
)