1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools git-2
8 DESCRIPTION
="An MPD client that submits information to Audioscrobbler"
9 HOMEPAGE
="http://mpd.wikia.com/wiki/Client:Mpdscribble"
10 EGIT_REPO_URI
="git://git.musicpd.org/master/mpdscribble.git"
11 EGIT_BOOTSTRAP
="eautoreconf"
18 RDEPEND
=">=dev-libs/glib-2.16:2
19 ~media-libs/libmpdclient-9999
20 curl? ( net-misc/curl )
21 !curl? ( net-libs/libsoup:2.4 )"
27 use curl
&& myclient
=curl
29 --with-http-client=${myclient} \
30 --docdir="${EPREFIX}"/usr
/share
/doc
/${PF}
35 newinitd
"${FILESDIR}/mpdscribble.rc" mpdscribble
36 dodir
/var
/cache
/mpdscribble