1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools git-2
8 DESCRIPTION="A library handling connections to a MPD server"
9 HOMEPAGE="http://gmpc.wikia.com/wiki/Libmpd"
10 EGIT_REPO_URI="git://git.musicpd.org/master/${PN}.git"
11 EGIT_BOOTSTRAP="eautoreconf"
16 IUSE="doc static-libs"
18 RDEPEND=">=dev-libs/glib-2.16:2"
21 doc? ( app-doc/doxygen )"
25 $(use_enable static-libs static) \
26 --docdir="${EPREFIX}"/usr/share/doc/${PF}
31 use doc && emake -C doc doc
36 use doc && dohtml -r doc/html/*
37 find "${ED}" -name "*.la" -exec rm -rf {} + || die
38 rm "${ED}"/usr/share/doc/${PF}/{README,ChangeLog} || die