rename dot-vc2 to ston-atl
[myNix.git] / lbhost / ston-atl.nix
blobc51432a5aae25d1dbce2f36f6909fd2b54b38a0a
1 # Edit this configuration file to define what should be installed on
2 # your system.  Help is available in the configuration.nix(5) man page
3 # and in the NixOS manual (accessible by running ‘nixos-help’).
5 { config, lib, pkgs, ... }:
8   imports = lib.optionals (builtins.pathExists ./default.nix) [ ./default.nix ];
9   # Use the GRUB 2 boot loader.
10   boot.loader.grub.enable = true;
11   # boot.loader.grub.efiSupport = true;
12   # boot.loader.grub.efiInstallAsRemovable = true;
13   # boot.loader.efi.efiSysMountPoint = "/boot/efi";
14   # Define on which hard drive you want to install Grub.
15   boot.loader.grub.device = "/dev/vda"; # or "nodev" for efi only
17   swapDevices = [{
18     device = "/var/lib/swapfile";
19     size = 1 * 1024;
20   }];
22   networking.hostName = "ston-atl"; # Define your hostname.
24   # network configuration
25   # dhcpcd is not working well with ipv6,
26   # see https://nixos.wiki/wiki/Networking#Prefix_delegation_with_fixed_DUID
27   networking.dhcpcd.enable = false;
28   networking.interfaces.ens3.useDHCP = false;
29   networking.interfaces.ens3.ipv6.addresses = [{
30     address = "2001:19f0:5401:280:5400:4ff:fed2:df3e";
31     prefixLength = 64;
32   }];