16 inherit (config.lib.mylib)
20 hostname = config.networking.hostName;
21 normal-users = binding
26 (conf.name or "") != "root" &&
27 (conf.isNormalUser or (! (conf.isSystemUser or false)))
30 (config.users.users or { }) //
31 (config.users.extraUsers or { })
38 services.mysql = maybe' {
39 enable = trace "MySQL server Enabled" true;
40 package = pkgs.mariadb;
42 mysqld.bind-address = "localhost";
48 ensurePermissions = { "*.*" = "ALL PRIVILEGES"; };