clean configurations
[myNix.git] / lbhost / conf.syspkgs.nix
blob8144e83be56165c498c131920d9c4cccb92b4c8b
1 { config
2 , pkgs
3 , lib
4 , ...
5 }:
7 let
8   inherit (lib)
9     optionals
10     optionalAttrs
11     ;
12   has-X = config.services.xserver.enable or false;
13   hostname = config.networking.hostName;
16   environment.systemPackages = with pkgs; [
17     wget
18     curl
19     tree
20     unzip
21     unrar
22     gnutar
23   ] ++ (optionals has-X [
24     neovide
25     vlc
26     nomacs
27   ]);
28   programs.mosh = {
29     enable = true;
30   };
31   programs.tmux = {
32     enable = true;
33     keyMode = "vi";
34   };
35   programs.neovim = {
36     enable = true;
37     defaultEditor = true;
38     viAlias = true;
39     vimAlias = true;
40     withRuby = false;
41     withPython3 = false;
42     withNodeJs = false;
43     configure = {
44       customRC = ''
45         set runtimepath^=~/.vim runtimepath+=~/.vim/after
46         let &packpath = &runtimepath
47         source ~/.vimrc
48       '';
49     };
50   };
51   programs.firefox = optionalAttrs has-X {
52     enable = true;
53   };