17 hostname = config.networking.hostName;
18 normal-users = binding
23 (conf.name or "") != "root" &&
24 (conf.isNormalUser or (! (conf.isSystemUser or false)))
27 (config.users.users or { }) //
28 (config.users.extraUsers or { })
35 services.mysql = maybe' {
36 enable = trace "MySQL server Enabled" true;
37 package = pkgs.mariadb;
39 mysqld.bind-address = "localhost";
45 ensurePermissions = { "*.*" = "ALL PRIVILEGES"; };