1 # Edit this configuration file to define what should be installed on
2 # your system. Help is available in the configuration.nix(5) man page
3 # and in the NixOS manual (accessible by running ‘nixos-help’).
5 { config, lib, pkgs, ... }:
8 imports = lib.optionals (builtins.pathExists ./default.nix) [ ./default.nix ];
9 # Use the GRUB 2 boot loader.
10 boot.loader.grub.enable = true;
11 # boot.loader.grub.efiSupport = true;
12 # boot.loader.grub.efiInstallAsRemovable = true;
13 # boot.loader.efi.efiSysMountPoint = "/boot/efi";
14 # Define on which hard drive you want to install Grub.
15 boot.loader.grub.device = "/dev/vda"; # or "nodev" for efi only
17 networking.hostName = "van-vc2"; # Define your hostname.
19 # network configuration
20 # dhcpcd is not working well with ipv6,
21 # see https://nixos.wiki/wiki/Networking#Prefix_delegation_with_fixed_DUID
22 networking.dhcpcd.enable = false;
23 networking.interfaces.ens3.useDHCP = false;
24 networking.interfaces.ens3.ipv4.addresses = [{
25 address = "207.148.67.66";
28 networking.defaultGateway = "207.148.66.1";
29 networking.interfaces.ens3.ipv6.addresses = [{
30 address = "2401:c080:1400:484d:5400:04ff:fe56:0956";