merge the formfield patch from ooo-build
[ooovba.git] / package / util / makefile.mk
blob99573c19ffb0a80216eede109305afd87609ee67
1 #*************************************************************************
3 # DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
4 #
5 # Copyright 2008 by Sun Microsystems, Inc.
7 # OpenOffice.org - a multi-platform office productivity suite
9 # $RCSfile: makefile.mk,v $
11 # $Revision: 1.13 $
13 # This file is part of OpenOffice.org.
15 # OpenOffice.org is free software: you can redistribute it and/or modify
16 # it under the terms of the GNU Lesser General Public License version 3
17 # only, as published by the Free Software Foundation.
19 # OpenOffice.org is distributed in the hope that it will be useful,
20 # but WITHOUT ANY WARRANTY; without even the implied warranty of
21 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 # GNU Lesser General Public License version 3 for more details
23 # (a copy is included in the LICENSE file that accompanied this code).
25 # You should have received a copy of the GNU Lesser General Public License
26 # version 3 along with OpenOffice.org. If not, see
27 # <http://www.openoffice.org/license.html>
28 # for a copy of the LGPLv3 License.
30 #*************************************************************************
32 # 2 == Unicode
33 MAJOR_VERSION=2
35 PRJ=..
36 PRJNAME=package
37 TARGET=package
39 ENABLE_EXCEPTIONS=TRUE
40 USE_DEFFILE=TRUE
41 NO_BSYMBOLIC=TRUE
44 # --- Settings -----------------------------------------------------
46 .INCLUDE : settings.mk
48 .IF "$(L10N_framework)"==""
50 # --- General ----------------------------------------------------
52 LIB1TARGET= $(SLB)$/$(TARGET).lib
53 LIB1FILES= \
54 $(SLB)$/zipapi.lib \
55 $(SLB)$/zippackage.lib \
56 $(SLB)$/manifest.lib
58 # --- Shared-Library -----------------------------------------------
60 SHL1TARGET=$(TARGET)$(MAJOR_VERSION)
61 SHL1IMPLIB=i$(TARGET)
62 SHL1VERSIONMAP=$(SOLARENV)$/src$/component.map
64 SHL1STDLIBS=\
65 $(CPPULIB) \
66 $(UCBHELPERLIB) \
67 $(CPPUHELPERLIB) \
68 $(COMPHELPERLIB) \
69 $(SALLIB) \
70 $(ZLIB3RDLIB)
72 SHL1DEF=$(MISC)$/$(SHL1TARGET).def
73 SHL1LIBS=$(LIB1TARGET)
74 DEF1NAME=$(SHL1TARGET)
76 .ENDIF # L10N_framework
78 # --- Targets ----------------------------------------------------------
80 .INCLUDE : target.mk